Установка форума PunBB 1.2

Установка и настройка форумов, CMS и прочих веб-приложений

Модератор: doliar

Правила форума
По вопросам настройки и установки коммерческих web приложений (IPB, DLE, vBulletin и т.д.) обращайтесь в техническую поддержку данных web приложений.

На данном форуме не рекомендуется создавать темы по вопросам настройки и установки коммерческих web приложений.

Re: Установка форума PunBB 1.2

Сообщение DPX-Infinity » 07 апр 2008, 13:36

при создании тем дата берётся из твоей системы. На всякий случай можешь проверить настройки даты и времени в "Options" в админке.
Изображение
Переходите на Jabber! За ним будущее!
Желаю вам опенсорса!
Аватара пользователя
DPX-Infinity
Активный участник
 
Сообщения: 723
Зарегистрирован: 02 сен 2007, 20:45
Откуда: Саратов

Re: Установка форума PunBB 1.2

Сообщение doliar » 07 апр 2008, 16:13

А вот у меня есть ещё одна беда,и заключаеться она вот в чём :
Когда я пишу на своём форуме буквы ( ш , И) то они отображаються не буквами,а значками (? ) !

Вот пример (Пи??ите) !
Как это можно исправить?
Изображение

Консультаций по TBDev через icq неосуществляю!
Аватара пользователя
doliar
Автор
 
Сообщения: 732
Зарегистрирован: 16 янв 2008, 15:05
Откуда: Саратов, Волжский р-он
Домен: tbdev-info.vfose.ru

Re: Установка форума PunBB 1.2

Сообщение DPX-Infinity » 07 апр 2008, 19:09

doliar писал(а):А вот у меня есть ещё одна беда,и заключаеться она вот в чём :
Когда я пишу на своём форуме буквы ( ш , И) то они отображаються не буквами,а значками (? ) !

Вот пример (Пи??ите) !
Как это можно исправить?

кодировки кривые. копай настройки базы по поводу кодировок.
Изображение
Переходите на Jabber! За ним будущее!
Желаю вам опенсорса!
Аватара пользователя
DPX-Infinity
Активный участник
 
Сообщения: 723
Зарегистрирован: 02 сен 2007, 20:45
Откуда: Саратов

Re: Установка форума PunBB 1.2

Сообщение Coolman » 07 апр 2008, 21:44

doliar писал(а):А вот у меня есть ещё одна беда,и заключаеться она вот в чём :
Когда я пишу на своём форуме буквы ( ш , И) то они отображаються не буквами,а значками (? ) !

Вот пример (Пи??ите) !
Как это можно исправить?

А ты не пробовал создавать Базу Данных с кодировкой UTF8?
Изображение
Coolman
Автор
 
Сообщения: 30
Зарегистрирован: 20 фев 2008, 14:56
Откуда: Саратов
Домен: All-Games.vFOSe.Ru

Re: Установка форума PunBB 1.2

Сообщение Coolman » 12 апр 2008, 10:53

К вашему сведению: форум PunBB создан с кодировкой UTF8 и я уверен что БД нужно создавать с такой же кодировкой!
Изображение
Coolman
Автор
 
Сообщения: 30
Зарегистрирован: 20 фев 2008, 14:56
Откуда: Саратов
Домен: All-Games.vFOSe.Ru

Русские кнопки в ответе для форума

Сообщение Coolman » 12 апр 2008, 14:22

Русские кнопки в ответе для форума!

Установка:
Заменить файл в папке с вашим форумом ...\include\attach\post_buttons.php файлом с архива
post_buttons.zip
(2.5 Кб) Скачиваний: 213


© Copyright Coolman
Изображение
Coolman
Автор
 
Сообщения: 30
Зарегистрирован: 20 фев 2008, 14:56
Откуда: Саратов
Домен: All-Games.vFOSe.Ru

Архив с форумом в первом посте

Сообщение Coolman » 23 апр 2008, 17:32

Обновил архив с форумом в первом посте!

Нововведения:
1. Добавлены русские кнопки
2. Удален баг с копирайтом

Также, можно обновить уже установленный вами бывший форум (при старом архиве). Если у вас уже стоит этот форум, то необходимо заменить файлы в вашем форуме файлами с нового архива.
Необходимо заменить:
...\include\attach\post_buttons.php - чтобы были русские кнопки
footer.php - чтобы не было бага с копирайтом
Изображение
Coolman
Автор
 
Сообщения: 30
Зарегистрирован: 20 фев 2008, 14:56
Откуда: Саратов
Домен: All-Games.vFOSe.Ru

Re: Установка форума PunBB 1.2

Сообщение Moran » 28 апр 2008, 23:17

У меня та же проблема, что и в первом посте!
"Эта сборка использует utf-8 кодировку, но ваш интерпретатор PHP сконфигурирован без поддержки utf-8. В PHP для Windows достаточно убрать комментарий в php.ini в строке extension=php_mbstring.dll"
Убрал extension=php_mbstring.dll из php.ini, не помогло. может надо комп перезагрузить? не знаю что делать.. помогите!
Аватара пользователя
Moran

 
Сообщения: 3
Зарегистрирован: 07 фев 2008, 19:41
Домен: x-sive.vfose.ru

Re: Установка форума PunBB 1.2

Сообщение Moran » 30 апр 2008, 10:44

предыдущую проблему решил, вот с администрированием возникла неполадка! Когда я изменяю раздел Options, и пытаюсь его сохранить, ошибку пишет, типа неправильный юрл.
Неверный HTTP_REFERER. Если вы перенесли эти форумы в новое место или сменили домен, вам необходимо сменить Base URL вручную в базе данных (ищите o_base_url в таблице config) после этого необходимо очистить кеш - стереть все .php файлы в папке /cache.

Как это исправить? В моей базе данных?
Аватара пользователя
Moran

 
Сообщения: 3
Зарегистрирован: 07 фев 2008, 19:41
Домен: x-sive.vfose.ru

Re: Установка форума PunBB 1.2

Сообщение Ivantrs » 04 май 2008, 12:31

Форум установился без проблем...
Будем смотреть, что у него внутри...
Пока увидел только ошибки в русском переводе... :)
Кое-что поправил в переводе...
Прикрутил русские надписи на кнопках в посте...
Заменил смайлики на Квиповские... упарился с их размером... (кому интересно - пишите, расскажу)
Запусил тестовый майл-сервер для нормальной работы форума...
Исправил баг с выводом русских имен в списке активных юзеров (проблема в таблице БД)

Кому интересно, пишите, расскажу как настроить Apache+PHP+MySQL+CourierMS+PunBB
Вложения
ivantrs.vfose.ru.gif
ivantrs.vfose.ru.gif (3.19 Кб) Просмотров: 6787
Последний раз редактировалось Ivantrs 10 май 2008, 02:49, всего редактировалось 4 раз(а).
Аватара пользователя
Ivantrs
Активный участник
 
Сообщения: 99
Зарегистрирован: 20 апр 2008, 12:08
Откуда: Энгельс
Домен: ivantrs.vfose.ru

Пред.След.

Вернуться в Установка веб-приложений

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron